USB auf RS485 Adapter

Moderator: Mod-Team

 

0.00 (0 Bewertungen)

Re: USB auf RS485 Adapter

Beitragvon gexle1004 » 17.07.2018, 08:55

ManfredR hat geschrieben:Hi,
wenn das nach 1-2 Monaten auftritt, dann hat der Konverter sich mal kurz ab- und wieder angemeldet. Dabei bekommt er bei Linux einen neuen Port zugewiesen. Den o.g. Test musst Du als sudo durchführen, also "sudo ./d0-fb -p /dev/serial/…"

Viele Grüsse,
Manfred


Hallo Manfred

Was meinst du genau zwecks Test ums Port auszulesen über SSH oder die Zeile in der start.sh??

Das komische war dann auch das er über d0-fb testen mir die Daten ausgelesen hat aber in Solarview Weboberfläche nichts angezeigt hat...

Ich werd mal das Netzteil tauschen ist zwar das von revolt das mit 2,5A und die Spannung kann man einstellen nun ja...

Mfg
gexle1004
Vielschreiber
Vielschreiber
 
- Threadstarter -
 
Beiträge: 191
Registriert: 29.08.2014, 17:24
Wohnort: Österreich/Tirol
PV-Anlage [kWp]: 5,5
Info: Betreiber

Re: USB auf RS485 Adapter

Beitragvon gexle1004 » 17.07.2018, 19:48

ManfredR hat geschrieben:Hi,
wenn das nach 1-2 Monaten auftritt, dann hat der Konverter sich mal kurz ab- und wieder angemeldet. Dabei bekommt er bei Linux einen neuen Port zugewiesen. Den o.g. Test musst Du als sudo durchführen, also "sudo ./d0-fb -p /dev/serial/…"

Viele Grüsse,
Manfred


Hallo manfred

Ich muss also das so in die start.sh das reinschreiben oder wie das es funktioniert??

sudo ./d0-fb -p /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9IZQAY1-if00-port0 -l 11000 -mb -ispeed 9600
gexle1004
Vielschreiber
Vielschreiber
 
- Threadstarter -
 
Beiträge: 191
Registriert: 29.08.2014, 17:24
Wohnort: Österreich/Tirol
PV-Anlage [kWp]: 5,5
Info: Betreiber

Re: USB auf RS485 Adapter

Beitragvon gexle1004 » 19.07.2018, 14:43

Hallo

Kann den solarview mit dem befehl in der start.sh was anfangen wenn ich den das so eintrage..??

./d0-fb -p /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9IZQAY1-if00-port0 -l 11000 -mb -ispeed 9600



Mfg
gexle1004
Vielschreiber
Vielschreiber
 
- Threadstarter -
 
Beiträge: 191
Registriert: 29.08.2014, 17:24
Wohnort: Österreich/Tirol
PV-Anlage [kWp]: 5,5
Info: Betreiber

Re: USB auf RS485 Adapter

Beitragvon gexle1004 » 25.07.2018, 19:47

Ja so funktioniert das auch....

Danke
gexle1004
Vielschreiber
Vielschreiber
 
- Threadstarter -
 
Beiträge: 191
Registriert: 29.08.2014, 17:24
Wohnort: Österreich/Tirol
PV-Anlage [kWp]: 5,5
Info: Betreiber

Re: USB auf RS485 Adapter

Beitragvon Weidemann » 02.08.2018, 21:52

Der Befehl mit /dev/serial/by-id/ funktioniert anscheinend nicht, wenn man mehrere baugleiche Adapter hat, denn in dem Fall wird bei mir nur einer angezeigt.

In dem Fall hilft "udev" weiter, damit kann man die verschiedenen USB-Geräte zur Not auch nach Steckplätzen verlinken. So hab ich das mit meinen billig-China-Adaptern gemacht, weil die nichtmal verschiedene Seriennummern hinterlegt haben ;-)
sonnige Grüße,
-Weidemann-
Weidemann
Moderator
 
Beiträge: 8158
Registriert: 09.08.2009, 12:01
Wohnort: Bayern
PV-Anlage [kWp]: 14
Info: Betreiber

Re: USB auf RS485 Adapter

Beitragvon gexle1004 » 31.08.2018, 08:14

Hallo

Kann ich eingendlich ein S0 Adapter auch über dessen ID ansprechen??

https://www.amazon.de/gp/product/B004ZM ... UTF8&psc=1

Geht das auch??

Danke
gexle1004
Vielschreiber
Vielschreiber
 
- Threadstarter -
 
Beiträge: 191
Registriert: 29.08.2014, 17:24
Wohnort: Österreich/Tirol
PV-Anlage [kWp]: 5,5
Info: Betreiber

Re: USB auf RS485 Adapter

Beitragvon gexle1004 » 12.09.2018, 18:09

Hallo

Habe heute wieder das Problem das Solarview mir nichts anzeigt obwohl Daten kommen konnte diese auslesen..

sudo ./d0-fb -p /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9IZQAY1-if00-port0 -l 11000 -mb -ispeed 9600

Aber Solarview log nichts mit bzw. keine Darstellung des ganzen

Was kann den da los sein???

Stimmt mit der start.sh etwas nicht??



Danke
Dateianhänge
rs485.rar
(988 Bytes) 3-mal heruntergeladen
gexle1004
Vielschreiber
Vielschreiber
 
- Threadstarter -
 
Beiträge: 191
Registriert: 29.08.2014, 17:24
Wohnort: Österreich/Tirol
PV-Anlage [kWp]: 5,5
Info: Betreiber

Re: USB auf RS485 Adapter

Beitragvon gexle1004 » 12.09.2018, 19:20

Hab noch was vergessen

Bei Monat Jahr und Gesamt hats mit gezählt bei Tag ist nichts drinnen auch unten steht die 0...verstehe das nicht..

Danke
gexle1004
Vielschreiber
Vielschreiber
 
- Threadstarter -
 
Beiträge: 191
Registriert: 29.08.2014, 17:24
Wohnort: Österreich/Tirol
PV-Anlage [kWp]: 5,5
Info: Betreiber

Re: USB auf RS485 Adapter

Beitragvon gexle1004 » 14.09.2018, 16:06

Hallo

Bin etwas weiter gekommen...nach Ertragserfassung läuft das Ding wieder über D0 wird alles wieder angezeigt..D0 V1.13

Kann das sein das die wie soll ich sagen die Ertragserfassung bzw. nach 1/2 Monaten rücksetzt??

Wie der Fehler auftratt habe ich geschaut per D0 Test ob Daten kommen das machten sie...

Dann Ertragserfassnung gemacht und alles wa wieder da auch PAC die momentane Leistung...

Vorher stand alles auf Null auch die momentane Leistung...kann das sein?

Danke
gexle1004
Vielschreiber
Vielschreiber
 
- Threadstarter -
 
Beiträge: 191
Registriert: 29.08.2014, 17:24
Wohnort: Österreich/Tirol
PV-Anlage [kWp]: 5,5
Info: Betreiber

Vorherige

Zurück zu SolarView



Ähnliche Beiträge


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast