Geräte mit Home Manager koppeln via SEMP (Ethernet)

Sunny Home Manager, SMA Data Manager, Sunny Portal, Sunny Places

Moderator: Mod-Team

 

5.00 (4 Bewertungen)

Re: Geräte mit Home Manager koppeln via SEMP (Ethernet)

Beitragvon Maverick78 » 09.08.2018, 08:05

Gar nicht klingt gut. Im Idealfall Timeframes entfernen.
2,55 kWp, SMA SB2.5, 25° SW, 30° Neigung, 10x ZNShine PV-tech ZXP6-60-255/P (09/2015)
9,54 kWp, SMA STP9000TL-20, 25° SW, 7° Neigung, 36 x Heckert Solar NeMo P265W (04/2016)
24,3 kWh Hoppecke PzS, SMA SI6.0H-11 (09/2016)
2x VW e-Golf 300
1x BWWP
Benutzeravatar
Maverick78
Fleißiges Mitglied
Fleißiges Mitglied
 
Beiträge: 441
Registriert: 16.11.2015, 11:23
Wohnort: Frankenhöhe
PV-Anlage [kWp]: 12,09
Speicher [kWh]: 24,3
Info: Betreiber

Re: Geräte mit Home Manager koppeln via SEMP (Ethernet)

Beitragvon camueller » 09.08.2018, 21:11

Maverick78 hat geschrieben:Nach einem OFF vom SHM während eines Timeframes läuft noch alles gut. Wenn aber wieder ein ON kommt, schaltet der SAE sofort in CHARGE_COMPLETED, weil er ja schon mal C erreicht hatte. Dabei löscht er die Timeframes. Danach schaltet er wieder auf VEHICLE_CONNECTED und das spiel beginnt von vorne.


Weil nach dem Einschaltbefehl der Status-Übergang von B auf C einige Minuten dauern kann, sind leider zu diesem Zeitpunkt die Bedingungen zum Erkennen des Ladeende erfüllt. Um das zuvermeiden, wird jetzt nach dem Einschaltbefehl die Status-Erkennung für 5 Minuten unterbrochen. Dieser Wert (Angabe in Sekunden) läßt sich in der Konfguration ändern:

Code: Alles auswählen
<EVModbusControl idref="wallbox" slaveAddress="180" startChargingStateDetectionDelay="300">


Dies ist die einzige Änderung im Snapshot 1.3.15 den es hier gibt:
https://github.com/camueller/SmartAppli ... r?raw=true
Benutzeravatar
camueller
Fleißiges Mitglied
Fleißiges Mitglied
 
Beiträge: 495
Registriert: 07.11.2015, 08:57
Wohnort: Altenstadt (Hessen)
PV-Anlage [kWp]: 9,36
Info: Betreiber

Re: Geräte mit Home Manager koppeln via SEMP (Ethernet)

Beitragvon Maverick78 » 09.08.2018, 21:59

Gerade noch rechtzeitig für den Nachttest ;)
2,55 kWp, SMA SB2.5, 25° SW, 30° Neigung, 10x ZNShine PV-tech ZXP6-60-255/P (09/2015)
9,54 kWp, SMA STP9000TL-20, 25° SW, 7° Neigung, 36 x Heckert Solar NeMo P265W (04/2016)
24,3 kWh Hoppecke PzS, SMA SI6.0H-11 (09/2016)
2x VW e-Golf 300
1x BWWP
Benutzeravatar
Maverick78
Fleißiges Mitglied
Fleißiges Mitglied
 
Beiträge: 441
Registriert: 16.11.2015, 11:23
Wohnort: Frankenhöhe
PV-Anlage [kWp]: 12,09
Speicher [kWh]: 24,3
Info: Betreiber

Re: Geräte mit Home Manager koppeln via SEMP (Ethernet)

Beitragvon camueller » 10.08.2018, 20:39

Maverick78 hat geschrieben:Gerade noch rechtzeitig für den Nachttest ;)

Neues Material zum Nachtesten :lol:

Maverick78 hat geschrieben:
Code: Alles auswählen
<Status>Off</Status>

Dadurch kommt 1x pro Minute wieder der Einschaltrequest vom SHM.

Während der startChargingStateDetectionDelay wird jetzt immer "On" zurückgemeldet.

Maverick78 hat geschrieben:Außerdem ist der Parameter scheinbar fix auf 300. Ich habe nämlich startChargingStateDetectionDelay="180" gesetzt zum schnelleren Testen. Er meldet trotzdem 300.

War ein Dokumentationsfehler von mir. Richtig muss es so aussehen für z.B. 10 Minuten:
Code: Alles auswählen
<ElectricVehicleCharger startChargingStateDetectionDelay="600">


Es gibt den neuen Snapshot 1.3.16 mit diesen Änderungen:
https://github.com/camueller/SmartAppli ... r?raw=true

Axel
Benutzeravatar
camueller
Fleißiges Mitglied
Fleißiges Mitglied
 
Beiträge: 495
Registriert: 07.11.2015, 08:57
Wohnort: Altenstadt (Hessen)
PV-Anlage [kWp]: 9,36
Info: Betreiber

Re: Geräte mit Home Manager koppeln via SEMP (Ethernet)

Beitragvon Maverick78 » 10.08.2018, 21:15

Ist eingebaut, werd aber morgen Abend erst zum Auswerten kommen, habe Kindergeburtstag .. Ick freu mir :ironie:
2,55 kWp, SMA SB2.5, 25° SW, 30° Neigung, 10x ZNShine PV-tech ZXP6-60-255/P (09/2015)
9,54 kWp, SMA STP9000TL-20, 25° SW, 7° Neigung, 36 x Heckert Solar NeMo P265W (04/2016)
24,3 kWh Hoppecke PzS, SMA SI6.0H-11 (09/2016)
2x VW e-Golf 300
1x BWWP
Benutzeravatar
Maverick78
Fleißiges Mitglied
Fleißiges Mitglied
 
Beiträge: 441
Registriert: 16.11.2015, 11:23
Wohnort: Frankenhöhe
PV-Anlage [kWp]: 12,09
Speicher [kWh]: 24,3
Info: Betreiber

Re: Geräte mit Home Manager koppeln via SEMP (Ethernet)

Beitragvon Maverick78 » 12.08.2018, 09:48

So kurze Zusamnmenfassung auch für die anderen, läuft einwandfrei.

Mal eine kleine Grafik von gestern bei wechselhafter Bewölkung.

daily.png
Dateianhänge
Screenshot_20180812_094740.png
hourly (3).png
2,55 kWp, SMA SB2.5, 25° SW, 30° Neigung, 10x ZNShine PV-tech ZXP6-60-255/P (09/2015)
9,54 kWp, SMA STP9000TL-20, 25° SW, 7° Neigung, 36 x Heckert Solar NeMo P265W (04/2016)
24,3 kWh Hoppecke PzS, SMA SI6.0H-11 (09/2016)
2x VW e-Golf 300
1x BWWP
Benutzeravatar
Maverick78
Fleißiges Mitglied
Fleißiges Mitglied
 
Beiträge: 441
Registriert: 16.11.2015, 11:23
Wohnort: Frankenhöhe
PV-Anlage [kWp]: 12,09
Speicher [kWh]: 24,3
Info: Betreiber

Re: Geräte mit Home Manager koppeln via SEMP (Ethernet)

Beitragvon camueller » 14.08.2018, 19:16

Nicatron hat geschrieben:Danke dass du das Zoe Problem nicht vergessen hast - ich habe einige male abends im dunkeln angesteckt und musste morgends die Zoe per Zentralverriegelungs-Fernbedienung wecken damit sie losläd. Damit das nicht passiert müsste auf jeden Status A-B übergang einmal 400=1 mit status C folgen. Dann bleibt sie wach/ansprechbar, egal wie lange es wieder bis C dauert.

Ich habe das jetzt implementiert - ging sehr fix: Falls das Property "forceInitialCharging" auf true gesetzt ist gilt Folgendes:
Sobald der Status nach Status A erstmalig auf B wechselt, wird 400=1 gesetzt. In diesem Fall wird 400=0 gesetzt, sobald der Status auf C.
Ist im nächsten Snapshot enthalten, den ich allerdings erst Anfang September bereitstellen werde.

Axel
Benutzeravatar
camueller
Fleißiges Mitglied
Fleißiges Mitglied
 
Beiträge: 495
Registriert: 07.11.2015, 08:57
Wohnort: Altenstadt (Hessen)
PV-Anlage [kWp]: 9,36
Info: Betreiber

Vorherige

Zurück zu SMA - Anlagenüberwachung



Ähnliche Beiträge


Wer ist online?

Mitglieder in diesem Forum: Vollmilch und 0 Gäste